请选择 进入手机版 | 继续访问电脑版

ITIL,DevOps,ITSS,ITSM,IT运维管理-ITIL先锋论坛

 找回密码
 微信、QQ、手机号一键注册

扫描二维码登录本站

QQ登录

只需一步,快速开始

查看: 148|回复: 0

[功能实施] iTop安装实施-安装手册-环境需求

[复制链接]
发表于 2020-12-11 11:18:12 | 显示全部楼层 |阅读模式
本帖最后由 adminlily 于 2020-12-11 11:21 编辑


需求及安装最低硬件需求
您的需求我们的建议
每月创建的工单控制台用户社区管理数据库:配置项伺服器中央处理器记忆MySQL磁盘
< 200< 20< 50k多功能服务器2vCPU4Gb10Gb
< 5000< 50< 200k两台服务器:网络 + MySQL4vCPU8Gb20Gb
> 5000> 50> 200k两台服务器:网络 + MySQL8vCPU16Gb50Gb

使用iTop的最小屏幕尺寸为1024 * 768像素,但解决越高越好。

我们建议使用运行Debian 9或Ubuntu 20.04 LTS的虚拟机

软件需求优拓服务器
iTop基于MySQL和PHP。

当然还有Web服务器:Apache和IIS已内置在配置中,其他Web服务器需要额外的工作(例如NGINX公司).

Graphviz需要显示影响度分析图。

所需的PHP扩展:ctype, dom, iconv, json, mbstring, mysqli, soap

php-gd是可选的,但要求能够使用CKEditor添加图像并自动调整HTML字段中的图像大小。

检查一下加密的数据有关如何安装到托管的加密字符串属性

要选择数据库版本,请检查版本的MariaDB发布注释和MySQL发布注意事项

伊托普                                                最低要求(建议)局限性
的PHP的MySQL玛丽亚数据库
2.3.x5.3.65.0
2.4.x5.3.65.5.3
2.5.x5.3.65.5.35.5
2.6.05.65.610.1MySQL 8无法正常运作,PHP 7.3和7.4无法正常运作
2.6.15.65.610.1MySQL 8不起作用,支持PHP 7.3
2.7.05.6
(7.3)
5.6
(5.7)
10.1
(10.4)
不建议将MySQL 8用于大型数据库,
支持PHP 7.4
不再支持IE9
2.8.07.15.710.3 ?MariaDB现在比MySQL更受青睐
不再支持IE11

iTop不支持具有多个主服务器的Galera群集,因为此类群集无法正确实现GET_LOCKMySQL职能(有关更多信息:Galera群集的已知局限性).

推荐的配置


可选要求:

与LDAP对接身份验证iTop需要PHP LDAP模块。如果不存在此PHP模块,则iTop将不支持LDAP或Active Directory标识。

网页浏览器
建议使用最新的Chrome版本(Firefox是安全的)。

  • 从2.7.0开始,不再支持IE9
  • 后续版本的iTop将不再支持任何Internet Explorer版本

架构约束
APCu

如果在多个实例上使用APCu,则在移至生产后,必须在所有实例上清除缓存。由于我们没有执行此操作的工具,因此实际上这意味着:

  • 重新启动所有Web服务器
  • 或不使用APCu


下载iTop

您可以从SourceForge下载iTop:https://sourceforge.net/projects/itop/files/itop

在Debian或Ubuntu 16.04及更高版本上安装前提条件
要在Ubuntu上安装所需的软件,请运行以下命令(以root用户身份):


apt-get install apache2
  apt-get install mariadb-server
  apt-get install php7.2 php7.2-mysql php7.2-ldap php7.2-cli php7.2-soap php7.2-


json graphviz
  apt-get install php7.2-xml php7.2-gd php7.2-zip libapache2-mod-php php7.2-


mbstring



apt-get install apache2
  apt-get install mysql-server
  apt-get install php php-mysql php-ldap php-cli php-soap php-json graphviz
  apt-get install php-xml php-gd php-zip libapache2-mod-php php-mbstring


从MySQL 5.7开始,根目录用户在MySQL中没有显式密码,因此您必须创建一个带有密码的用户用户来安装iTop。以下命令将创建具有所有特权的用户iTop。这对于测试很有用,但不是用于生产的最佳配置(因为账号很重要):

  须藤MySQL

登录MySQL后,执行以下命令:

GRANT ALL PRIVILEGES ON *.* TO 'iTop'@'%' IDENTIFIED BY 'some_password';
  FLUSH PRIVILEGES;


Redhat,CentOS或Fedora上安装必备组件
要在Redhat CentOS Fedora上安装所需的软件,请运行以下命令(以root用户身份):

yum install httpd
yum install mysql mysql-server
yum install php php-mysql php-xml php-cli php-soap php-ldap php-gd php-zip php-json

php-mbstring graphviz



Windows上安装先决条件在IIS上安装PHP
检查此页面: iTop和IIS

安装MySQL
如果您还没有MySQL数据库服务器,则可以将其安装在与应用其余部分相同的系统上。

转到MySQL的下载站点:http地址:w. mysql. commdownsmysqll

下载适合您的系统的安装程序:选择32位或64位版本名为“ MSI Installer”的软件包。

通过打开下载的.msi文件来启动安装。

按照安装向导的说明进行操作

其他依赖:图维兹
iTop依靠图形维兹产生对象生命周期的图形表示以及影响度分析图。

在Linux上,graphviz已经是上面定义的前提条件的一部分,因此没有其他事情要做。

在Windows上: 下载Graphviz从网站上进行安装。

在安装过程中,系统将提示您供应Graphviz的确切路径。预期的价值是dotexecutable的完整路径(在Windows上名为dot.exe)。
例如Linux上的userrbinndot和Windows上的C:\ Program文件(x86)\ Graphviz 2.68 \ bin \ dot.exe。







上一篇:iTop安装实施-安装手册
下一篇:iTop安装实施-安装手册-环境需求-iTop and Suhosin

本版积分规则

参加 ITIL 4 基础和中级专家认证、v3专家升级、DevOps专家认证、ITSS服务经理认证报名
本站关键字: ITIL| ITSM| ISO20000| ITIL培训| ITIL认证| ITIL考试| ITSS| ITSS培训| ITSS认证| IT运维管理| DevOps| DevOps培训| DevOps认证| itop| itil4| sre| 开源ITSM软件

QQ|小黑屋|手机版|Archiver|艾拓先锋网 ( 粤ICP备11099876号-1 )|网站地图

Baidu

GMT+8, 2021-4-14 10:25 , Processed in 0.163234 second(s), 30 queries .

Powered by Discuz! X3.4 Licensed

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表