请选择 进入手机版 | 继续访问电脑版

IT运维管理,ITIL,ITSS,ITSM,ISO20000-ITIL先锋论坛

 找回密码
 微信、QQ、手机号一键注册

扫描二维码登录本站

QQ登录

只需一步,快速开始

艾拓先锋
搜索
查看: 537|回复: 2

[提问与解答] 安装iTop过程出错,求指点

[复制链接]
来自- 广东佛山

参加活动:0

组织活动:0

发表于 2018-11-2 11:48:47 | 显示全部楼层 |阅读模式 来自- 广东佛山
Install or Upgrade choice
在这个步骤时,下边有红色的警告信息,然后继续执行后边的操作,安装不成功
( ! ) Warning: mysqli::mysqli():  in C:\wamp\www\iTop\web\core\cmdbsource.class.inc.php on line 86
Call Stack
#TimeMemoryFunctionLocation
10.0000282504{main}(  )..\ajax.dataloader.php:0
20.06248937048WizStepInstallOrUpgrade->AsyncAction(  )..\ajax.dataloader.php:150
30.06248937456SetupUtils::AsyncCheckDB(  )..\wizardsteps.class.inc.php:315
40.06248937904SetupUtils::CheckServerConnection(  )..\setuputils.class.inc.php:978
50.06248938984CMDBSource::Init(  )..\setuputils.class.inc.php:912
60.06248940488mysqli
(  )..\cmdbsource.class.inc.php:86



QQ截图20181102114733.png
来自- 陕西西安

参加活动:0

组织活动:0

发表于 2019-4-4 10:45:08 来自手机 | 显示全部楼层 来自- 陕西西安
数据库与PHP的组件安装错误
来自- 广东

参加活动:0

组织活动:0

发表于 2019-4-4 15:18:43 | 显示全部楼层 来自- 广东
楼上的正确,说提详细点就是由于你安装的php-mysqli版本过低导致的,卸载使用mysqlnd即可;解决方法如下:
yum remove php-mysqli
yum -y install php72w-mysqlnd    (此处看你安装什么版本的php,比如PHP5.6就是yum -y install php56w-mysqlnd)
以上回复希望对你有用。

本版积分规则

选择云运维时代的王牌讲师-长河老师,助你轻松入门ITIL Foundation培训课程

QQ|小黑屋|手机版|Archiver|艾拓先锋网 ( 粤ICP备11099876号-1|网站地图

Baidu

GMT+8, 2019-4-20 16:49 , Processed in 0.194197 second(s), 32 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表